K&B Prologue Installation Problems

Page 2 of 3 Previous  1, 2, 3  Next

View previous topic View next topic Go down

Re: K&B Prologue Installation Problems

Post by Eyrion on Fri 11 Oct 2013 - 18:04


I just did that... Still not working properly. I've patched everything and even reinstalled Age of Empires 2 times. I have the "To Program Files" folder extracted into my C:\Program Files (x86)\Steam\steamapps\common\Age Of Empires 3\bin. Just can't solve where my "Knights and Barbarians" folder goes.

Eyrion
Hobilar
Hobilar

Age : 21
Posts : 29
Join date : 2013-10-07

Back to top Go down

Re: K&B Prologue Installation Problems

Post by NomadicAI7 on Sun 3 Nov 2013 - 19:23

Hi Knights and Barbarians Team!

First of all, let me congratulate you on the auspicious release of your fantastic mod! I'm really digging all the descriptions of the factions released so far. Can't wait for Quintessence factions, especially the Mongols Very Happy Turks and Saracens very well done from what I surmise. Also, interesting how Byzantines get Kukicher Archers? They’re mercenary Cuman/Kipchak archers? Huanglukuzhou could probably use the model for Age of Steppes mod, which I’ve been following all this time. Heck, once my TWC and Skyrim mods would quiet down, I might just try my hand at AOE3 modding. AOE is still my MOST favorite RTS. TW isn’t quite pure RTS, yet I still love it.

However, I'm having trouble installing K&B on my Steam copy of AOE3 GOTY version, with all AOE3, TWC, and TAD patched to 1.03 version.

Here is what I experienced. I was able to reproduce all three errors I've gathered from this thread and the initial Download Thread:

I create a back-up of my bin folder where most STEAM AOE3 files are located. For example, binORIGINAL for when I’m trying on mods (modded bin staying as default “bin”), and binMOD when I’m going back to vanilla (renaming binORIGINAL back to bin). Perhaps the game still looks into the binORIGINAL folder, but I doubt it.

Error #1: Nothing Happens.
IF as instructed, I put the Knights & Barbarians>RM3 folder into My Games folder as a separate, standalone Knights & Barbarians folder, then the CUSTOM maps do not show up.
Actually, they NEVER show up for me if I rely on ONLY this standalone Knights & Barbarians folder for My Games folder.

Error #2: DATAPY.BAR ERROR
“INITIALLIZATION FAILED. COULD NOT FIND DATAPY.BAR”
Next, I tried the peugeot47’s trick of multiple AOE3 instances (D, K, N, O, W) by copying the bin folder into Program Files(x86)/Microsoft Games/Age of Empires III folder (renaming bin to Age of Empires III).
Everything almost worked, but then I got hit with the DATAPY.BAR error, no doubt trying to find the Steam connection API/ID, I think.

Error #3: aiStandardLoader Error
"XS Error 0003: could not compile 'ailoaderstandard.xs' "
To get the CUSTOM maps to show up, I tried putting the contents of that RM3 folder into the Age of Empires 3 folder inside My Games folder, and it worked.
I was able to tick on Custom Maps checkmark in Skirmish and load the map.
However, I encountered the aiStandardLoader error everytime.

Strangely enough, moving the contents of “To Program Files” folder into My Games>Age of Empires 3 folder enabled most of the icons, so now I could see Turks, Saracens… before they were Italians with Venice flag.
Only by moving the contents of “To Program Files” folder into My Games>Age of Empires 3 folder brought the Turks and Saracens icons up on Create Home City screen. This is very odd.
Why would a PREFERENCE Saver/Save Folder be overriding the game and not the actual BIN folder in the Steam directory for the game?
Also, even with the DATAPI and AISTANDARDLOADER errors, I was able to get into game, but no new buildings, textures, units show up, so I think the problem is deeper than just a missing AI loader.
I don’t understand. PLEASE NEED HELP!

Also, as a last resort, I tried installing with SCP ModLoader.
Very weird results, but worse since NO mod factions and even TWC factions don’t show up when normally they should. Also, the flag is obnoxiously enlarged for some reason.
One good boon of SCP ModLoader is that it somehow doesn’t mess with the bin folder. If clicking on normal Steam Play on TAD, original, unmodified TAD is brought forth.

Even with Patch 1 (I see some new ui and graphics, sweet!), this last “aiStandardLoader” error persists!
Please somebody on K&B team, please include STEAM installation instructions.

Best regards,
Peace
~NAI7 on Nexus forums
TuranianGhazi on TWC and ModDB
Haterade on Steam

NomadicAI7
Peasant
Peasant

Posts : 5
Join date : 2013-11-03

Back to top Go down

Re: K&B Prologue Installation Problems

Post by AOE_Fan on Mon 4 Nov 2013 - 1:40

Hello and welcome!

You need to delete all the .xmb files in the "data" folder in your Aoe3 bin folder (\Steam\steamapps\common\Age Of Empires 3\bin\data), that should work. I'll add instructions for this into the main post, since this seems to be a common problem...

AOE_Fan
K&B Leader
K&B Leader

Posts : 3615
Join date : 2011-05-27

Back to top Go down

Re: K&B Prologue Installation Problems

Post by NomadicAI7 on Mon 4 Nov 2013 - 16:31

Hi AOE_Fan!

Thanks for responding! Yes, I read this thread folder and found the solution (deleting .XMB files in "data" folder only). I was able to make K&B work! YAY!

Your post confirmed this. Also, may you please include these Steam instructions into the main download's instructions notes. That would be helpful.

Basically what worked for me is the following:
1) Deleting .xmb files in the "data" folder in oe3 bin folder (\Steam\steamapps\common\Age Of Empires 3\bin\data)
2) ALSO this. Placing Knights & Barbarians/RM3 folder contents into Age of Empires 3/RM3 folder. Only this way the maps were recognized as Custom and able to be loaded.

I played one game as the Turks allied with Saracens against Byzantines allied with Crusaders on Bosphorus map.

I played another game as the Saracens allied with Turks against Venetians allied with Crusaders on Crusader Stronghold map.

Yes, I have lots of impressions. Overall, very positive, but I just have suggestions here and there. I'll find the appropriate thread and list my early mod impressions and suggestions in there.

Kudos on very fine work! I REALLY dig all the new units.

I mean I expected the Man-at-Arms to be same-looking for all civs.. I was pleasantly surprised that they were differentiated in looks. A Turk Man-at-Arms looks different than a Saracen Man-at-Arms, even though they're both Muslim factions. Also, really loving all the unique units like the Farimba, Ahdath, and so on.

Congratulations on a splendid and historic AOE3 mod!

Hopefully, come mid-January, I'll have more time and may try offering my modding skills (texturing/mesh modelling) and join K&B team. I'd like to work first on Mongols but then help out with all other civs Very Happy

Best!

NomadicAI7
Peasant
Peasant

Posts : 5
Join date : 2013-11-03

Back to top Go down

Re: K&B Prologue Installation Problems

Post by AOE_Fan on Tue 5 Nov 2013 - 5:25

Good to know that you got it to work, I also added those instructions into download notes for Steam users.
The next patch doesn't require installing anything to My Documents folders by the way so installing should be easier in the future. There will also be a cool installer/autopatcher for Windows users that makes installing and patching even easier but we'll tell more about that when the artwork is finished... Wink

Thanks for your comments and feedback as well! The Mongols will indeed be one of our main priorities, along with Spanish as Moors.

AOE_Fan
K&B Leader
K&B Leader

Posts : 3615
Join date : 2011-05-27

Back to top Go down

Re: K&B Prologue Installation Problems

Post by NomadicAI7 on Tue 19 Nov 2013 - 9:57

Had loads of fun with the Byzantines, Venetians, and Crusaders.

Byzantines out of them all felt like most powerful. Least powerful felt were Venetians, seemed like they needed a buff of sorts. However, maybe I'm just playing them wrongly.

Questions:
1) What does the merchant do? I haven't figured out how that works. Basically an early way to Sell/Trade before the Market building?
2) What is this silver-tinted resource? Piety? How to accumulate it? Have more priests/imams out? They should be doing something like tending to Farms or what? Confused about this.
3) Oh boy Manor building is very important and I keep forgetting to build it (some laughter ensued). Also, School is very important, especially for end-game Black Powder/Gunpowder upgrade that enables all the muskets/gun units.

Anyways, some bugs I found. I'll post here but also in the Bug thread once I find it.

1. Cog doesn't fish when the tooltip says that it is able to fish.
2. Computer AI on islands get stuck on that island, they don't settle other islands or push the player island much. No naval landings/invasions. (some laughter ensued) reminds me of early Total War games with little to none naval invasions.
3. Farmers' creations of Wood and Orchards sometimes linger for a loong while, much more than in vanilla AOE3
4. Acute Framedrops here and there. Never had framerate problems in AOE3, ever. Something the mod does looks like is performance-heavy.
5. Some other ones I'm forgetting at the moment. Will come back and update with more.
Sorry if some or all of these have been mentioned already.

NomadicAI7
Peasant
Peasant

Posts : 5
Join date : 2013-11-03

Back to top Go down

Re: K&B Prologue Installation Problems

Post by peugeot407 on Tue 19 Nov 2013 - 10:42

Have you installed the latest patch? That might fix the framerate drops, and perhaps some of the other bugs as well (haven't got a changelist at hand)

The Italians only have an average military, and don't receive much uniqueness in that department, but their core strength is their economy. Before releasing the Prologue, we actually had to tone them down a bit, because their superb economy made them very OP...


peugeot407

_________________
Synecdoche wrote: Do you only use your wisdom teeth to grind down bone from your kills?



Sola Scriptura. Sola Fide. Sola Gratia. Solus Christus. Soli Deo Gloria.




peugeot407
K&B Founder
K&B Founder

Age : 25
Posts : 6423
Join date : 2010-07-23

http://twitter.com/rjfaber91

Back to top Go down

Re: K&B Prologue Installation Problems

Post by NomadicAI7 on Wed 20 Nov 2013 - 7:29

Oh no I did not have the patch 1.0.1 of that writing. Now I do.

Installed the patch. Everything seems ok. It didn't say patch 1.0.1 on the splash screen though.

However, I played a Skirmish on Fast and no stutters or framerate drops. Yay! Well done!

Yeah, Italians do seem strong now that I considered their full card availabilities (edited to have full civs with all cards available, etc.). While their army is rather weak comparatively, their crazy economy more than makes up for that. And given that skirmishers and spearmen are a hard counter to most unique units anyways, just focusing on an infantry army and spamming them with that powerful econ is the way to go. However, I never viewed Italians as mass charge forces... more finesse, based on my readings of Machiavelli's The Prince, with perhaps much cheaper Mercenary units from the Saloon. Or perhaps that IS the way to use more powerful use for the Italians, to abuse the economy to field powerful Mercenary units. Fun fun fun!


Okies, I gots some more questions:
1) Why can't my MILITARY units help kill predators (bears, foxes, wolves) for villagers? For example, this scenario happened to me lots of times
-I want to build a Tower or a Trading Post with a villager or two
-I send them off. On their way they get attacked by Brown Foxes, Bears, what have you
-My army can't target these creatures and watches the villagers die. Sadface

2) Walls only near Town Centers and Fortresses. I guess this is to discourage many walling exploits. However, I rely upon them when I alone fight against 3 or more Hard or Expert CPUs. With this change, it's virtually impossible to channel the Hard/Expert CPU forces down a narrower corridor

3) Turk-specific: First three Observatories provide great LOS as described. However, on 4th, 5th Observatory does not for some reason. It's just a building with very minimal LOS right around its foundational base.

4) While I like the Fast mode, but I feel like it's considerably faster than AOE3 Fast speed, a tad too much perhaps. The battles stream so fast that no TACTICAL decisions (which units target which other units, trying to counter precisely) are possible to be made, only STRATEGIC (army composition to ensure balance)

I guess I'm asking for a Fast Speed but in between the slowww Medium and the current ultra-Fast mode. Medium is reaal sloww... I can't imagine playing on Slow speed (some laughter ensued)

NomadicAI7
Peasant
Peasant

Posts : 5
Join date : 2013-11-03

Back to top Go down

Re: K&B Prologue Installation Problems

Post by AOE_Fan on Wed 20 Nov 2013 - 8:41

1. It's annoying (although you could just use your villagers to kill the huntables, not that hard if you have all HP upgrades) but it'll be changed in patch 2.0.
2. The reason is indeed to prevent walling your enemy off but it also makes players to think more of their Town Center/Fort placement. The system also represents medieval defenses more accurately as you'd hardly find a piece of wall build randomly somewhere...
3. There aren't any problems code-wise ("not fixeable") but you don't really need a fourth Observatory anyway unless you're playing with a large number of players in a very large map.
4. K&B doesn't change the speed of the game at all. However there's no denying that the Fast speed on Vanilla is way too fast to be able to play properly.

Also responding to your earlier comments:
- The Merchant will probably change a bit once we'll find a better and more defined use for him. While the extra resource allows many possibilities, I'd personally prefer to keep it pretty simple.
- What do you mean with the "silver-tinted resource", Trade or Papal Favour?
- Unfortunately Aoe3's AI simply cannot be made to settle other islands. They do attack over water but it sometimes doesn't work very well, which can't be changed either.

AOE_Fan
K&B Leader
K&B Leader

Posts : 3615
Join date : 2011-05-27

Back to top Go down

Re: K&B Prologue Installation Problems

Post by kicho on Sun 19 Jan 2014 - 13:27

hi!
i have just downloaded this mod + patch and i installed it, but when i runned a game and select the civ, the only possible civ that i can choose are cinese, portoghesi, saraceni..
please help me Sad

p.s i have follow all step to copy files...

kicho
Peasant
Peasant

Posts : 3
Join date : 2014-01-19

Back to top Go down

Re: K&B Prologue Installation Problems

Post by Vvv on Sun 19 Jan 2014 - 13:42

Is it the Steam version? If is, just delete all .XMB files in the data folder.

Vvv
Voulgier
Voulgier

Age : 17
Posts : 146
Join date : 2012-10-01

Back to top Go down

Re: K&B Prologue Installation Problems

Post by kicho on Sun 19 Jan 2014 - 23:02

i have age of empires III complete edition.. i dont know if it is steam.. an other error is the ailoader.xs, dont make a abitants in the centre of city buildings and the abitants dont work..

kicho
Peasant
Peasant

Posts : 3
Join date : 2014-01-19

Back to top Go down

Re: K&B Prologue Installation Problems

Post by AOE_Fan on Sun 19 Jan 2014 - 23:21

Please, try deleting ALL .xmb files in your Aoe3 "data" folder (C:\Program Files(x86)\Steam\steamapps\common\Age Of Empires 3\bin\data).

AOE_Fan
K&B Leader
K&B Leader

Posts : 3615
Join date : 2011-05-27

Back to top Go down

Re: K&B Prologue Installation Problems

Post by kicho on Mon 20 Jan 2014 - 2:30

ok now run thanks! but i can choose only three civ.. why?

kicho
Peasant
Peasant

Posts : 3
Join date : 2014-01-19

Back to top Go down

Re: K&B Prologue Installation Problems

Post by Dirtyadams on Mon 10 Mar 2014 - 7:42

I'm not being able to play the game as well.  I've reinstalled it a few times under user/--/documents/mygames/knights and barbarians  but everytime I reinstall age3y.exe it is "unable to locate component".  It says, "This application has failed to start because RockallDLL.dll was not found.  Re-installing the application may fix this problem."  I have reinstalled, as I said, but with no avail.  Let me know if there is any thing I can do, or if I am putting it in the wrong location!  Thanks you guys

Dirtyadams
Peasant
Peasant

Posts : 5
Join date : 2014-03-10

Back to top Go down

Re: K&B Prologue Installation Problems

Post by Dirtyadams on Mon 10 Mar 2014 - 7:45

Sorry but addon to my question...should I put the application under Microsoft/Windows/Startupmenu/Programs instead of /mygames under documents and user?

Dirtyadams
Peasant
Peasant

Posts : 5
Join date : 2014-03-10

Back to top Go down

Re: K&B Prologue Installation Problems

Post by Dirtyadams on Mon 10 Mar 2014 - 8:01

And lastly I'm not running the game within steam, and I have updated AOE 3 as well. To narrow down the issue  Smile

Dirtyadams
Peasant
Peasant

Posts : 5
Join date : 2014-03-10

Back to top Go down

Re: K&B Prologue Installation Problems

Post by peugeot407 on Mon 10 Mar 2014 - 8:08

In the future, please edit your existing post rather than making new ones in direct succession...

I'll leave AOE_Fan to answer your question, as he's considerably more qualified than me to do so.


peugeot407

_________________
Synecdoche wrote: Do you only use your wisdom teeth to grind down bone from your kills?



Sola Scriptura. Sola Fide. Sola Gratia. Solus Christus. Soli Deo Gloria.




peugeot407
K&B Founder
K&B Founder

Age : 25
Posts : 6423
Join date : 2010-07-23

http://twitter.com/rjfaber91

Back to top Go down

Re: K&B Prologue Installation Problems

Post by AOE_Fan on Mon 10 Mar 2014 - 8:52

The correct folder to install is C:\Program Files (x86)\Microsoft Games\Age of Empires III. If you're using Windows, the K&B Installer should help you.

AOE_Fan
K&B Leader
K&B Leader

Posts : 3615
Join date : 2011-05-27

Back to top Go down

Re: K&B Prologue Installation Problems

Post by Dirtyadams on Mon 10 Mar 2014 - 14:52

sorry about that. I've never actually signed up for any type of gamesite before like this. But I was excited to play yours and it didn't look like there was an answer to my question. So from here on out I'll edit my older posts. thanks AOE_Fan!

Dirtyadams
Peasant
Peasant

Posts : 5
Join date : 2014-03-10

Back to top Go down

Re: K&B Prologue Installation Problems

Post by spangopola on Fri 28 Mar 2014 - 13:58

So someone on the Taiwanese forum reported that he got this problem of receiving a message called Floating point division by zero.

Help?

spangopola
Moderator
Moderator

Age : 23
Posts : 1342
Join date : 2010-08-02

Back to top Go down

Re: K&B Prologue Installation Problems

Post by peugeot407 on Fri 28 Mar 2014 - 19:48

I have heard of it before, but I can't quite remember what the cause of it was, I'm afraid...


peugeot407

_________________
Synecdoche wrote: Do you only use your wisdom teeth to grind down bone from your kills?



Sola Scriptura. Sola Fide. Sola Gratia. Solus Christus. Soli Deo Gloria.




peugeot407
K&B Founder
K&B Founder

Age : 25
Posts : 6423
Join date : 2010-07-23

http://twitter.com/rjfaber91

Back to top Go down

Re: K&B Prologue Installation Problems

Post by AOE_Fan on Fri 28 Mar 2014 - 21:10

It's a problem with Windows XP users but it should get fixed with the new version that I'm going to upload this weekend. Smile

AOE_Fan
K&B Leader
K&B Leader

Posts : 3615
Join date : 2011-05-27

Back to top Go down

Re: K&B Prologue Installation Problems

Post by spangopola on Sat 29 Mar 2014 - 2:12

Good gracious, please give me the new version when it's done XD

spangopola
Moderator
Moderator

Age : 23
Posts : 1342
Join date : 2010-08-02

Back to top Go down

Re: K&B Prologue Installation Problems

Post by AOE_Fan on Wed 2 Apr 2014 - 19:34

Sorry for not being able to upload the new version: the exams limited my time quite a bit and now I managed to get myself ill (a really great birthday...). I'll try to get it up asap though

AOE_Fan
K&B Leader
K&B Leader

Posts : 3615
Join date : 2011-05-27

Back to top Go down

Re: K&B Prologue Installation Problems

Post by Sponsored content


Sponsored content


Back to top Go down

Page 2 of 3 Previous  1, 2, 3  Next

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum