Unknown problem trying to get hidden apple tree model in scenario editor

View previous topic View next topic Go down

Unknown problem trying to get hidden apple tree model in scenario editor

Post by dietermoreno on Fri 19 Sep 2014 - 5:52

Unknown problem trying to get the hidden apple tree model into the scenario editor.

Yes the file paths are correct, I think.

The model works, I opened it up in Granny Viewer.

When I try to place the apple tree on the ground in scenario editor, I place invisible trees.

I tried changing the model the anim file references to from apple tree to berry bush and the unit is still invisible, so it appears its not a problem of a bad model.

So perhaps the anim file is broken or my proto entry is wrong?

So where is the error?


anim file:
tree_apple.xml
Code:

<?xml version="1.0" encoding="utf-8"?>

<animfile>
<component>
ModelComp
<assetreference type="GrannyModel">
<file>terrain\trees\tree_apple_a</file>
</assetreference>
</component>
<anim>
Idle
<component>ModelComp</component>
</anim>
</animfile>


proto entry:

Code:

<Unit id ='43760' name ='AppleTree'>
<DBID>43760</DBID>
<DisplayNameID>43761</DisplayNameID>
<EditorNameID>43760</EditorNameID>
<ObstructionRadiusX>0.4900</ObstructionRadiusX>
<ObstructionRadiusZ>0.4900</ObstructionRadiusZ>
<MaxVelocity>0.0000</MaxVelocity>
<MovementType>land</MovementType>
<AnimFile>terrain\tree_apple.xml</AnimFile>
<ImpactType>Wood</ImpactType>
<Icon>terrain\trees\berrybush_icon_64</Icon>
<PortraitIcon>terrain\trees\berrybush_portriat</PortraitIcon>
<RolloverTextID>43762</RolloverTextID>
<ShortRolloverTextID>43762</ShortRolloverTextID>
<InitialResource resourcetype ='Food'>1000.0000</InitialResource>
<ResourceSubType>forage</ResourceSubType>
<BuildingWorkRate>1.0000</BuildingWorkRate>
<MinimapColor red ='0.5000' blue ='0.2500' green ='0.2000'></MinimapColor>
<UnitType>LogicalTypeMinimapFilterEconomic</UnitType>
<UnitType>LogicalTypeVillagersRespondToAttack</UnitType>
<UnitType>Food</UnitType>
<UnitType>Resource</UnitType>
<UnitType>Nature</UnitType>
<UnitType>AbstractFruit</UnitType>
<Flag>StartsAtFullEfficiency</Flag>
<Flag>Immoveable</Flag>
<Flag>NoBloodOnDeath</Flag>
<Flag>ObscuresUnits</Flag>
<Flag>NoIdleActions</Flag>
<Flag>NonAutoFormedUnit</Flag>
<Flag>Doppled</Flag>
<Flag>SelectWithObstruction</Flag>
<Flag>PaintTextureWhenPlacing</Flag>
<Flag>FlattenGround</Flag>
<Flag>NotDeleteable</Flag>
<Flag>ForceToGaia</Flag>
<Flag>ObscuredByUnits</Flag>
<Flag>DieAtZeroResources</Flag>
<Flag>Invulnerable</Flag>
<Flag>DoNotValidateResourceInventory</Flag>
<Flag>Tracked</Flag>
<Command page ='10' column ='0'>Delete</Command>
</Unit>

dietermoreno
Enemy of the Realm
Enemy of the Realm

Age : 25
Posts : 121
Join date : 2012-12-29

http://youtube.com/dietermoreno

Back to top Go down

Re: Unknown problem trying to get hidden apple tree model in scenario editor

Post by checanos on Sat 20 Sep 2014 - 0:56

It works for me, it must be that you did not match the anim file in the proto entry.


This is so cool, a new berry bush! Thanks Dietermoreno for finding this.

checanos
Peasant
Peasant

Age : 19
Posts : 15
Join date : 2012-06-02

Back to top Go down

Re: Unknown problem trying to get hidden apple tree model in scenario editor

Post by Pepp on Sat 20 Sep 2014 - 2:02

I can make it an orange or lemon tree too! Thanks!

_________________
Philosophy of gaming: A player is a noobish modder; a modder is a noobish player.

Spoiler:
The Pepp Noble Way to Make and Drink Tea
Pepp's Eye Candy thread
Pepp's First Random Map Script!

Pepp
Moderator
Moderator

Age : 20
Posts : 5277
Join date : 2011-04-29

Back to top Go down

Re: Unknown problem trying to get hidden apple tree model in scenario editor

Post by dietermoreno on Sun 21 Sep 2014 - 15:56

I'm sorry for my stupidity at not being able to figure out what I mistyped. Checanos, can you please copy and paste your proto entry and anim file code here so I can compared to see what lines are different in mine?

dietermoreno
Enemy of the Realm
Enemy of the Realm

Age : 25
Posts : 121
Join date : 2012-12-29

http://youtube.com/dietermoreno

Back to top Go down

Re: Unknown problem trying to get hidden apple tree model in scenario editor

Post by checanos on Wed 12 Nov 2014 - 8:28

Sorry for not responding to your post earlier Dietermoreno. I don't check the forums very often.

dietermoreno wrote:I'm sorry for my stupidity at not being able to figure out what I mistyped.  Checanos, can you please copy and paste your proto entry and anim file code here so I can compared to see what lines are different in mine?
I just copied your animfile and the proto was  just of another unit that I temporarily swapped.  It must that the animfile name does not match up.

checanos
Peasant
Peasant

Age : 19
Posts : 15
Join date : 2012-06-02

Back to top Go down

Re: Unknown problem trying to get hidden apple tree model in scenario editor

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum